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7th and sth Plugins for Adobe CC and Nuke

7th and sth Plugins for Adobe CC and Nuke

7thSense Design has plugins for the popular design and compositing suites, Adobe® After Effects
and Media Encoder, and Nuke® from The Foundry, that convert movie media into the optimised .7th
file format, which then also allows for encryption using the 7thSense Content Protection System
application.

This new 2021 plugin for Adobe Media Encoder .uses the Adobe MediaCore API that can
be used in After Effects or Premiere Pro, or directly in Adobe Media Encoder. Available for
Windows and macOS, it includes reading and writing between .7th files and any other
format, so can be used very flexibly.

Plugin v.2.0 for Nuke  Reader and Writer, with revised interface and increased read/write
format range.

The original plugin for After Effects  did not offer reading, only writing.
After Effects can also batch export to 32-bit TGA, which can be converted to .7th format
using the 7thSense DFM application.

Original v.1 Plugin for Nuke . .7th format 4:2:2 files are saved as the equivalent .sth
extension.

Download links are provided in these pages. For further help on media plugins, please contact
support@7thSense.one.
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AdobeMediaCore7th Plugin

Introduced in 2021, this Adobe MediaCore plugin offers maximum flexibility. It reads .7th files and
writes any format out to .7th formats, and is accessible in Media Encoder directly, and for use with
After Effects and Premiere Pro. For example, in After Effects, Choose File > Export > Add to Media
Encoder Queue and Media Encoder will open. Your After Effects composition will appear in the Media
Encoder queue, and Media Encoder can then do the rendering, freeing up After Effects to continue
working.

Downloads

Right-click to download (save link as) zip files of Adobe MediaCore7th:

Ø Adobe MediaCore7th (Windows) 

Ø Adobe MediaCore7th (MacOS)

Formats supported

Format Import Export

8-bit YCoCg DXT5     

8-bit YCbCr 4:2:0     

8-bit YCbCr 4:2:2     

10-bit YCbCr 4:2:2     

12-bit RGB 4:4:4     

8-bit RGB 4:4:4    

8-bit RGBA 4:4:4    

8-bit BGRA 4:4:4    

Compatibility

Creative Cloud CC2019-, 64-bit for Windows and macOS. (Note that Apple Silicon is not supported.) 
For example After Effects connects directly with Media Encoder:

https://portal.7thsense.one/user-guides/resources/AdobeMediaCore7th-Win.zip
https://portal.7thsense.one/user-guides/resources/AdobeMediaCore7th-MacOS.zip


6

M252-8 7th Format Plugins for Adobe and Nuke : User Guide 
 
                                                                                   © 2024 7thSense

7th and sth Plugins for Adobe CC and Nuke

Installation: Windows

There are two files:

· Exporter7th.prm

· Importer7th.prm

Place these in C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore. Admin privileges are
required to write to this folder.

To test if the importer plugin has loaded correctly, run Adobe Media Encoder and browse to a folder
with .7th or .sth files (RGB or YCbCr 4:2:2) and thumbnails should appear in the Media Browser
window. To test if the exporter plugin has loaded correctly, run Adobe Media Encoder and create a
new export job – the new exporter should be present under the title ‘7thSense’. If installing over an
existing plugin, preferences may not display correctly. Delete the Adobe Media Encoder preferences
file (typically under Users\[USERNAME]\Documents\Adobe\Adobe Media Encoder\[VERSION]
\Presets\PresetTree.xml) and restart Media Encoder.
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7th and sth Plugins for Adobe CC and Nuke

Installation: macOS

There are two installers:

· Exporter7th.bundle

· importer7th.bundle

Copy these to /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore. Admin
privileges are required to write to this folder.

If these subfolders do not exist, just create them.

On your Mac, use Extensions settings to enable and disable Apple and third-party extensions for your
Mac and select extensions to include in the Share menu. Extensions, such as Markup, add extra
functionality to apps, the Finder and the Touch Bar.

To change these settings, select Apple menu > System Settings, click Privacy & Security in the sidebar,
then click Extensions on the right.

To test if the importer plugin has loaded correctly, run Adobe Media Encoder and browse to a folder
with .7th or .sth files (RGB or YCbCr 4:2:2) and thumbnails should appear in the Media Browser
window. To test if the exporter plugin has loaded correctly, run Adobe Media Encoder and create a
new export job – the new exporter should be present under the title ‘7thSense’. If installing over an
existing plugin, preferences may not display correctly. Hold down the Shift key while loading Adobe
Media Encoder or Premiere Pro to delete the plugin cache.

Application

Importer, from Media Encoder

1. Select File > Add Source from the menu.

2. Select the first and last files in the .7th movie sequence you wish to import.

3. Ensure ‘7thSense Importer Format Sequence’ is checked.

4. Click ‘Open’ and the still frame sequence should be imported as a movie clip to the encoder
queue.

Exporter, from Media Encoder

1. Import the movie clips to the encoder queue.

2. Click on the ‘Format’ cell to bring up the ‘Export Settings’ dialog.

3. Click the ‘Format’ drop-down menu and select ‘7thSense’.

4. Select the desired output codec using the ‘Codec’ drop-down menu in the ‘Video codec settings’
group.
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Exporter, from Adobe After Effects

The MediaCore exporter is supported in After Effects via Adobe Media Encoder. Select ‘Add to Adobe
Media Encoder Queue’ to import the composition to Adobe Media Encoder, and then follow the steps
for Adobe Media Encoder from step 2 onward.
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7th and sth Plugins for Adobe CC and Nuke

Nuke7th Plugin v.2

This 2021 rework of the Nuke reader/writer plugin expands the range of formats available, with a
revised user interface.

Downloads

Right-click to download (save link as) zip files of the Nuke7th plugin:

Ø Nuke7th Plugin v.2 (Windows) 

Ø Nuke7th Plugin v.2 (Linux)

Formats supported

Format Import Export

8-bit YCoCg DXT5     

8-bit YCbCr 4:2:0     

8-bit YCbCr 4:2:2     

10-bit YCbCr 4:2:2     

12-bit RGB 4:4:4     

8-bit RGB 4:4:4    

8-bit RGBA 4:4:4    

8-bit BGRA 4:4:4    

Compatibility

Nuke 12.1v5, 12.2v2 and 12.2v5; 13.0v2 on Windows, Ubuntu 18.04, and CentOS 7.9.

https://portal.7thsense.one/user-guides/resources/Nuke7th-Win.zip
https://portal.7thsense.one/user-guides/resources/Nuke7th-Linux.zip
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Installation

There are 2 .dll (CentOS: .so files): sthReader and sthWriter, for this plugin.

The zip package for each platform contains all the files needed to load the plugins in Nuke.

https://learn.foundry.com/nuke/developers/63/ndkdevguide/intro/pluginbuildinginstallation.html

Windows

Extract and copy the contents of the downloaded zip package to Nuke user home folder, e.g. C:
\Users\[USERNAME]\.nuke.

https://learn.foundry.com/nuke/developers/63/ndkdevguide/intro/pluginbuildinginstallation.html
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Linux

Extract and copy the contents of the downloaded zip package to Nuke user home folder, e.g. /home/
[USERNAME]/.nuke.

Nuke7th Reader/Writer

From Nuke, select from the STH Options:

Export to either file type .7th or .sth. These are equivalent to Delta Media Servers. Historically in Nuke,
handling files with numeric characters has caused issues.
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7th and sth Plugins for Adobe CC and Nuke

7th AfterEffects v.1 Plugin

Formats supported

This original plugin (issued 2016-2019) supports export of the 7th 4:2:2 8-bit and 7th 4:2:2 10-bit
image sequence format only. For importing and exporting and to more formats, see the Media
Encoder plugin , introduced by 7thSense in 2021.

Compatibility

Creative Cloud CC2019, 64-bit for Windows/macOS.

Downloads

Right-click to download the plugin (save link as):

Ø Adobe AfterEffects plugin (Windows) 

Installation: Windows

For a standard Windows installation using the latest Creative Cloud release, the 7thAE.aex file should
be copied to the following After Effect plugin location:

C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore

If this does not exist, the plugin copy it to the equivalent directory for your version of After Effects.

Installation: macOS

Before CC 2019:

For a Mac installation using the latest Creative Cloud release, the 7thAE.plugin package should be
copied to the following After Effects plugin location:

/Library/Application Support/Adobe/Common/Plug-ins/[CS version]/MediaCore/

CC2019, verified with Catalina 10.15.1:

Add 7thSense plugin to path:

/Applications/Adobe After Effects CC 2019/Plug-ins/Extensions Start After Effects. It will fail, but click
Cancel instead of moving it to the Bin. Shutdown After Effects.

5
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Go to the ‘Security & Privacy’ panel, ‘General’ tab. This will show that the plugin was recently
prevented from running. Click ‘Allow Anyway’.

Run After Effects again. This time an extra option of ‘Open’ is shown, select this. After clicking open
after effects will run and the plugin is seen.

Next time you start After Effects, you shouldn’t see the prompt but the plugin should be available for
use.

Application

For 7th 4:2:2 10-bit render output, it is important that the After Effects project ‘Project Settings’ are
configured to output a depth higher than the default 8-bit. There is no 10 or 12bit project depth option,
only 8, 16 & 32bit (float):

For 10-bit renders you need at least a 16 bits per channel.

To configure the render output for 7th 4:2:2 10-bit:
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Note: you can only do 24-bit RGB renders, not RGB+A (32-bit).

The depth of ‘millions of colours’ would produce 8-bit files, ‘trillions of colours’ gives 10-bit.
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Nuke7th Plugin v.1

Nuke does not recognise numeric characters in filenames. .7th format files need therefore to be
saved to .sth file extensions.

Formats supported

This plugin supports export of 4:2:2 10-bit and YCoCg, and the 7th 4:2:2 or sth 4:2:2 8-bit image
sequence format.

Compatibility

Nuke 9, 10 and 11 for Windows, macOS, Linux.

Installation

Once built, your plug-in binary (a shared library with the appropriate .dylib/.so/.dll extension
depending on your platform) will need to be placed in a path where NUKE scans for plug-ins on
startup. On all platforms this will be either your ~/.nuke (i.e. <user home directory>/.nuke/, where the
dot prefix may mean it is hidden by default in your file browser), or somewhere in your NUKE_PATH
which defaults to:

· macOS 64-bit: /Library/Application Support/NUKE/x.x/plugins/

· Linux 64-bit: /usr/local/NUKE/x.x/plugins/

· Windows 64-bit: C:\Program Files\Common Files\NUKEx.xplugins

Where <x.x> is the major.minor version of the NUKE in question. Conveniently, NUKE_PATH can be
added to by setting an environment variable of the same name. This is often of use when building
and testing plug-ins, because you can set an environment variable pointing at your build directory and
then fire up NUKE to try it out.

It is recommended when packaging up NDK plug-ins for distribution that you use the NUKE_PATH
directories, and install your bundle in an appropriately named subdirectory (since the default path is
searched single level recursively).

There are several ways to add a plug-in to your current session.

· Hit x to bring up the script command and type in the name of the plug-in and hit enter. If the plug-
in is found in the various paths searched for the plug-in, an instance is added to the Node Graph.
This is generally of most use when first setting up plug-ins. If this fails, you may want to try the
script command ‘load <my plug-in name>’ which tests that the plug-in can be found and that
dynamic loading works. The common reasons why this might not work is that the
DD::Image:::Op::Description is incorrect, or that the plug-in has been built against a different
version of the NDK than that supported by the version of NUKE you’re trying to load it into.
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· Go to the Other > All plug-ins menu and hit update, or hit tab and type update-enter. Both of these
add the full list of found plug-ins to the menu (and thus tab selector), allowing them to be added
by the usual means. Again, this is generally of most use when first setting up plug-ins.

· You can add your own menu entry to the default toolbar by adding a menu.py file to the
NUKE_PATH and following the guidelines laid out in the Python Reference Guide. This is
recommended for packaging up plug-ins for distribution as it allows easy discovery of your tools.
Additionally, any pre-requisite Python elements can be initialised in menu or init.py, including the
usual icons and so on.

sth422Reader / Writer

This is a Nuke File Reader plugin to read 10-bit and 8-bit 4:2:2 .sth and .7th files. A .sth/.7th file
represents a frame of media to be used for playback with Delta Media Servers.

There is a 7thReader.tcl file: please place this in the .nuke directory along with the plugins. This file
allows the sthReader to be loaded when a .7th file is read.

sth Output Options from Nuke

The plugin allows selection of file extension, bit-depth and compression:



18

M252-8 7th Format Plugins for Adobe and Nuke : User Guide 
 
                                                                                   © 2024 7thSense

7th and sth Plugins for Adobe CC and Nuke

Output .sth as .7th
check this to rename the extension from .sth to .7th.

If neither of the two following options are ticked, output is 4:2:2 8-bit. Otherwise:

Output YCoCg
select to output with this compression type (8-bit only)

or

Output 10bit Per Pixel
select to output 4:2:2 10-bit

A Point to Consider

· When using the sth422Writer and sth422Reader to write your Nuke render to a .7th or .sth format,
and then subsequently read it back into Nuke, you will see a change in the RGB values compared
to your original in Nuke. This is to be expected.
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· The reason is that each Red, Green and Blue pixel value in Nuke is represented as a 32-bit float,
and when the data is saved to file, these values are converted to 8 or 10-bit. This is necessary to
make them compatible with 8 or 10-bit .sth or .7th files. This process causes the original data to
be approximated so the information can be encoded within the specified number of bits. When
the data is then read back using the sth422Reader, it begins its conversion process at the saved
approximated value. Therefore, after the reader has done its processing and fed that information
back to Nuke, it will give slightly different RGB values to those originally created in Nuke.

· For this reason, it is recommended that content creation and changes are done on the original
Nuke node and not on a node that has been read from the sth422Reader. The reader should be
used primarily for checking frames, not editing.
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Document Information

Date Document
edition

Software
version

Revision Details Author

July 2016 1 Adobe CC 64-bit for Windows/macOS, plugin
v.1.0
Nuke 8 or 9 for Windows, macOS, Linux, plugin
v.1.0

New release Elliot Byrne

June 2017 2 Adobe CC 64-bit for Windows/macOS, plugin
v.1.0
Nuke 9 or 10 for Windows, macOS, Linux, plugin
v.1.0-1

Updated, republished Andie
Davidson

March 2018 3 Adobe CC 64-bit for Windows/macOS, plugin
v.1.0
Extended to Nuke 11, plugin v.1.0-2

Writer can now output 4:2:2 10 bit and YCoCg,
as well as original 4:2:2 8 bit,
Reader can now read 4:2:2 10 bit as well as
original 4:2:2 8 bit.

Andie
Davidson

February
2019

4 Adobe CC 64-bit for Windows/macOS, plugin
v.1.0
Nuke Reader/Writer plugin 1.1

Updated, republished Andie
Davidson

November
2019

5 Adobe CC 2019 and macOS Catalina 10.15,
plugin v.1.1
Nuke Reader/Writer plugin 1.1

Updated, republished Andie
Davidson

April 2021 6 Adobe CC 2021. Media Encoder plugin v.1.0.1
Beta
Nuke Reader/Writer Plugin 2.0.0
(Media Conversion Library 0.1.14 Beta)

Addition of Media Encoder plugin Andie
Davidson

August
2022

7 Adobe CC 2021. Media Encoder plugin v.1.0.1
Beta
Nuke Reader/Writer Plugin 2.0.0
(Media Conversion Library 0.1.14 Beta)

Download links added Andie
Davidson

June 2023 8 Adobe CC 2021. Media Encoder plugin v.1.1.1
Beta
Nuke Reader/Writer Plugin 2.0.0
(Media Conversion Library 0.1.14 Beta)

Download resources updated Andie
Davidson
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